Hudson logo

Failed

omsimulator.initialization.mos (from (result.xml))

Failing for the past 51 builds (Since Unstable#7320 )

Stacktrace

Output mismatch (see stdout for details)

Standard Output

 + initialization.mos                                                                ... equation mismatch [time: 1]

==== Log /tmp/omc-rtest-hudson/omsimulator/initialization.mos_temp7826/log-initialization.mos
true
""
"initialization.fmu"
""
true
""
139
"/bin/sh: line 1: 18030 Segmentation fault: 11  ( /Users/hudson/slave/workspace/OpenModelica_OSX_BUILD/OpenModelica/build/bin/OMSimulator initialization.lua )
"

Equation mismatch: diff says:
--- /tmp/omc-rtest-hudson/omsimulator/initialization.mos_temp7826/equations-expected2019-05-16 21:35:51.000000000 +0200
+++ /tmp/omc-rtest-hudson/omsimulator/initialization.mos_temp7826/equations-got2019-05-16 21:35:52.000000000 +0200
@@ -2,20 +2,8 @@
 ""
 "initialization.fmu"
 ""
 true
 ""
-0
-"info:    maximum step size for 'test.root': 0.100000
-info:    No result file will be created
-info:    Initialization
-info:      A.x_start: 1.5
-info:      A.x:       1.5
-info:      A.w:       1.5
-info:    Simulation
-info:      A.x_start: 1.5
-info:      A.x:       1.9080371522852
-info:      A.w:       2.3160743045704
-info:    Final Statistics for 'test.root':
-NumSteps = 37 NumRhsEvals  = 83 NumLinSolvSetups = 39
-NumNonlinSolvIters = 82 NumNonlinSolvConvFails = 0 NumErrTestFails = 18
+139
+"/bin/sh: line 1: 18030 Segmentation fault: 11  ( /Users/hudson/slave/workspace/OpenModelica_OSX_BUILD/OpenModelica/build/bin/OMSimulator initialization.lua )
 "

Equation mismatch: omc-diff says:
Line 7: Integer 0 != 139

== 1 out of 1 tests failed [omsimulator/initialization.mos_temp7826, time: 1]

Powered by Hudson Open Source Continuous Integration Server from the Eclipse Foundation